Skip to content
297a7bb4d3
Go to file
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

README.md

inc-validator-client

ValidatorClient - the Ruby gem for the Metadata Validation API

API for the metadata validation service.

This SDK is automatically generated by the Swagger Codegen project:

  • API version: 1.0.0
  • Package version: 1.0.1
  • Build package: io.swagger.codegen.languages.RubyClientCodegen

Installation

Build a gem

To build the Ruby code into a gem:

gem build inc-validator-client.gemspec

Then either install the gem locally:

gem install ./inc-validator-client-1.0.1.gem

(for development, run gem install --dev ./inc-validator-client-1.0.1.gem to install the development dependencies)

or publish the gem to a gem hosting service, e.g. RubyGems.

Finally add this to the Gemfile:

gem 'inc-validator-client', '~> 1.0.1'

Install from Git

If the Ruby gem is hosted at a git repository: https://github.com/GIT_USER_ID/GIT_REPO_ID, then add the following in the Gemfile:

gem 'inc-validator-client', :git => 'https://github.com/GIT_USER_ID/GIT_REPO_ID.git'

Include the Ruby code directly

Include the Ruby code directly using -I as follows:

ruby -Ilib script.rb

Getting Started

Please follow the installation procedure and then run the following code:

# Load the gem
require 'inc-validator-client'

api_instance = ValidatorClient::ValidationApi.new

begin
  #lists available validators
  result = api_instance.get_validators
  p result
rescue ValidatorClient::ApiError => e
  puts "Exception when calling ValidationApi->get_validators: #{e}"
end

Documentation for API Endpoints

All URIs are relative to http://localhost

Class Method HTTP request Description
ValidatorClient::ValidationApi get_validators GET /validators lists available validators
ValidatorClient::ValidationApi validate POST /validators/{validator_id}/validate performs a validation

Documentation for Models

Documentation for Authorization

All endpoints do not require authorization.

About

InCommon metadata validator API Ruby client

Resources

Releases

No releases published
You can’t perform that action at this time.